当前位置:首页 > 问答

k线副图指标公式

我来帮TA回答

通达信大盘K线副图公式为什么无法显示???

这个不是通达信的程序.
呵呵.

股票中什么是副图指标公式?

主图就像是你平时看到的K线图和分时线,一般占2/3的面积。
幅图就是平时看到MACD/KDJ/BBS等技术指标的地方。

求同花顺上证K线副图,或者上证KDJ线副图指标公式?

上证kdj:SZc:=INDEXDATA("1a0001",&INDEXC);
SZh:=INDEXDATA("1a0001",&INDEXH);
SZl:=INDEXDATA("1a0001",&INDEXL);
RSV=(SZc-LLV(SZl,9))/(HHV(SZh,9)-LLV(SZl,9))*100;
a=SMA(RSV,3,1);
b=SMA(a,3,1);
e=3*a-2*b;
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;
K:a;
D:b;
J:e;上证K线副图:Vc:=INDEXDATA("1A0001",&INDEXC);
Vo:=INDEXDATA("1A0001",&INDEXO);
Vh:=INDEXDATA("1A0001",&INDEXH);
Vl=INDEXDATA("1A0001",&INDEXL);STICKLINE(Vo>=Vc,Vc,Vo,7,0 ),colorcyan;
STICKLINE(Vo>=Vc,Vc,Vl,0.1,0 ),colorcyan;
STICKLINE(Vo>=Vc,Vo,Vh,0.1,0 ),colorcyan; STICKLINE(Vc>Vo,Vc,Vo,7,1),colorred;
STICKLINE(Vc>Vo,Vo,Vl,0.1,1),colorred;
STICKLINE(Vc>Vo,Vc,Vh,0.1,1),colorred; STICKLINE(Vc=vo AND Vc>REF(Vc,1),Vc,Vo,7,1 ),colorred;
STICKLINE(Vc=Vo AND Vc>REF(Vc,1),Vc,Vh,0.7,1 ),colorred;
STICKLINE(Vc=Vo AND vC>REF(Vc,1),Vo,Vl,0.7,1 ),colorred;
M5:MA(Vc,5),colorwhite;
m10:MA(Vc,10),Colorffaa66;
M30:MA(Vc,30),Color0055ff;
m60:MA(Vc,60),Color00ffff;

通达信 大盘指数作副图 指标编程代码!!

{上证指数K线副图指标}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
上证:"999999$C",COLORWHITE,NODRAW;
_±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
五:MA("999999$C",5),COLORWHITE;
十:MA("999999$C",10),COLORYELLOW;
二十:MA("999999$C",20),COLORMAGENTA;
六十:MA("999999$C",60),COLORGREEN;
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

关于金叉死叉.什么指标都可以.下面我发一个指标.源码如下:typ:=high+low+close

1.黄金交叉(金叉):指短期移动平均线向上穿过中期移动平均线或短期、中期移动平均线同时向上穿过长期移动平均线的走势图形,表示股价将继续上升。

死亡交叉(死叉):指下降中的短期移动平均线由上而下穿过下降的长期移动平均线,这个时候支撑线被向下跌破,表示股价将继续下落。

2.K线形态如下图所示:

求助高手,编写一个通达信K线头肩底选股公式

D:=15;FIRE:=3;
MACD:=BARSLAST("MACD.MACD"<REF("MACD.MACD",1))>=3;
A:=ZIG(4,D); B:=REF(A,1);
G:=CROSS(A,B); F:=CROSS(B,A);
VAR1:=REF(LOW,SUMBARS(G,3)); {左肩起涨低价}
VAR2:=REF(HIGH,SUMBARS(F,2)); {左肩最高价}
VAR3:=REF(HIGH,SUMBARS(F,1)); {右肩最高价}
VAR4:=REF(LOW,SUMBARS(G,2)); {头肩底价}
VAR5:=REF(LOW,SUMBARS(G,1)); {右肩回调低价}
买点1:=IF(VAR3>1.01*VAR2 AND VAR5>1.01*VAR1 AND VAR4<VAR1 AND BARSLAST(G)<3 AND MACD,1,0);
买点2:=IF(VAR3>1.01*VAR2 AND VAR5>1.01*VAR1 AND VAR4<VAR1 AND CROSS(CLOSE,VAR2),2,0);
买点3:=IF(VAR3>1.01*VAR2 AND VAR5>1.01*VAR1 AND VAR4<VAR1 AND CROSS(CLOSE,VAR3),3,0);
CHOICE:IF(FIRE=1,买点1,IF(FIRE=2,买点2,买点3));